How to configure Pidgin 2.5.2 in Ubuntu 8.10 (intrepid ibex) to use Google Talk

Pidgin it’s a chat client that support multiple protocols like:

  • AIM
  • Google Talk
  • IRC
  • MSN
  • MySpaceIM
  • XMPP
  • and more…

To install it in Ubuntu just run in the console:

sudo apt-get install pidgin

The first time you open it, it asks you to add an account:

Pidgin add account
Pidgin add account

Then you can choose which protocol to use. Here I’ve choosed “Google Talk” protocol and put my login info:

Pidgin with Google Talk protocol
Pidgin with Google Talk protocol

And its done :)

Pidgin Buddy List
Pidgin Buddy List

Upgrade to kernel-2.6.27-11-generic on LG-500

Today I’ve upgraded my kernel to 2.6.27-11-generic, and some fixes were necessary to get my Ubuntu to work again.

I tried to open VirtualBox but I get this error:

VirtualBox error
VirtualBox error

Executing the command that they suggest worked like a sharm:

sudo /etc/init.d/vboxdrv setup

The other problem was due to wireless. Again I needed to recompile the madwifi so I could get it to work for the new kernel. I’ve Followed the post Re: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01) and it’s working again! :)

Subclipse 1.4.7 in Eclipse 3.4 (Ganymede) using Ubuntu 8.10

Since I’ve made a Fresh Ubuntu install in my laptop, now I’ve to setup the environment so I can do some working in the laptop ;)

The company that I’m working now only uses PHP, so the production IDE that I use is Eclipse PDT. The great thing about Eclipse, is it’s huge plugin repository, and the one that’ll be talking here is the Subclipse.

Subeclipse is on 1.4.7 version and it’s a great SVN plugin (the only one I know ;)).

Installation Instructions

This installation instructions are based on Download and Install with the difference that here I’ll be showing Subclipse installation process for Eclipse 3.4 (Ganymede) and screens were captured in Eclipse 3.4.0 running on Ubuntu 8.10.

Step 1:

Begin the installation from the Eclipse Help menu item.

Software Updates
Software Updates

Step 2:

This screen will vary depending on the features you have installed already. You want to click on the New Remote Site button. If you are behind a proxy and the Eclipse install mechanism does not work, then you can download a zipped version of the update site and then click the New Local Site button instead.

Software Updates and Add-ons
Software Updates and Add-ons

Step 3:

This screen is showing the Add Site dialog, filled in with the correct information to install Subclipse 1.4.7 (url: http://subclipse.tigris.org/update_1.4.x)

Add Site
Add Site

Step 4:

When you first come back to this screen, the site you added will NOT be selected. Be sure to select it before clicking Next.

Install
Install

Step 5:

This next screen shows all of the features that are available to install.

Confirm Install
Confirm Install

Step 6:

Click the button to accept the license agreement.

Confirm
Confirm

Step 7:

Eclipse needs to be restarted after installing Subclipse.

Restart
Restart

Step 8:

Finally, after restarting Eclipse, you can do Import and checkout a Project from SVN

Import
Import

Ubuntu 8.10 (Intrepid Ibex) in LG E500-SP23P laptop

I’ve done a fresh install of Ubuntu 8.10 (intrepid ibex) in my LG E500-SP23P laptop and I’ll document my troubles and my thoughts about the new Ubuntu version.
I’ve switched to Ubuntu since it’s 5.10 version and in this laptop since its 7.04. My previous version was 7.10 and some of the problems that I had in installing it then, I saw them in this new version too…
This laptop has the following specs:
Processor

  • Code Name: Meron
  • Processor: Intel Core 2 Duo Processor T7500
  • FSB: 800Mhz
  • Speed: 2.2Ghz
  • Cache: 4Mb L2 Cache
Graphic Card
  • NVIDIA® GeForce® 8400M 128Mb VRAM -TurboCache até 384/896Mb
Wireless Card
  • Atheros AR5007EG Wireless (802.11b/g)
Sound Card
  • Audio card Intel Corporation 82801G (ICH7 Family) High Definition
After installing it I’ve noticed that wireless didn’t work. In 7.10 it also didn’t work, so I expected that it should be fixed by now. After some googling I’ve find out how to solve this.
Another problem that I’ve faced was that I couldn’t activate Desktop Effects. I’ve went to System/Apperance and in the “Visual Effects” tab activated “Extra”. Here ubuntu showed me the option to activate the proprietary driver, and I choosed “Enable”.
Activate proprietary driver
Activate proprietary driver
So I choose to “Enable” and another error showed up:
Enable to enable driver
Enable to enable driver
Another problem that I had (I also had in 7.10 version and never could fix it) is that if I plugin headphones, I continue to ear sound from the front speakers.
I haven’t fix this yet, when (if) I do, I’ll let you know ;)
References: